I suggest you ...

Restore CTRL+click behavior

A recent change on Netvibes overrides browser ctrl+click behavior, which should open the link in a new tab while keeping focus on the existing page. CTRL+click (in Firefox and Chrome) is fundamental to the way I've used Netvibes for the past seven years as my primary internet dashboard. I read through the feeds on Netvibes, ctrl+click on the links I want to follow, so they open in new tabs but I stay on Netvibes. Then I ctrl+tab through the pages, reading, bookmarking or closing them. This worked until a month or two ago. Now ctrl+click is just the same as a click, opening a new tab and taking me there. Please put it back or offer an alternative key combination to do this.

20 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Doug shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    9 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • tc commented  ·   ·  Flag as inappropriate

        it still doesn't work in my FF 37.0.2
        and I REALLY miss it
        any chances on changing this?

      • Susanna commented  ·   ·  Flag as inappropriate

        Doesn't work in Chrome - I had it as right-click instead of ctrl-click but yes, as of today, it's broken.

        I absolutely cannot use Netvibes without this and will have to find a new RSS reader.

      • Itamar commented  ·   ·  Flag as inappropriate

        CTRL-click does not work properly from the Apps view on Firefox. Switches context to the new tab rather than staying on Netvibes.
        A fix would be highly appreciated.
        Thanks!

      • Michelle commented  ·   ·  Flag as inappropriate

        Likewise, this feature seemed to suddenly stop working for me fairly recently. Chrome 35.0.1916.153 on Mac OS X 10.6.8. Cmd-Tab used to open the post in a new tab in the background, but now it just opens the post view within Netvibes (from which I can then Cmd-Tab to a new tab). Kind of a drag. Is there a fix?

      • Itamar commented  ·   ·  Flag as inappropriate

        I use the Apps view on Chrome and the (essential) CTRL-click behavior stopped working for me as well a couple of days ago.
        Please restore this option!

      Feedback and Knowledge Base